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Integration for Eclipse via GDB

Version 04-Apr-2016

13-Apr-15 New document.

Introduction

The TRACE32 PowerView can be used as GDB backend (see "TRACE32 as GDB Back-End”

(backend_gdb.pdf)). This GDB interface is useful to access the TRACES32 debug functionality (go, break,
step, variable view, memory and register access...) from within Eclipse.
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In order to allow you to use these features, Lauterbach offers an Eclipse plug-in with a simplified and
adapted launch configuration.

NOTE: The Eclipse plug-in described in this document only simplifies the Eclipse
configuration to control TRACE32 using the GDB interface and offers the
possibility to configure and launch TRACE32 from within Eclipse.

Controlling TRACES2 through Eclipse as GDB backend can also be done using
the standard views offered by the Eclipse Debug Configurations window.

NOTE: The Eclipse plug-in described in this document is different from the Lauterbach

Eclipse “loose coupling” plug-in which is described in ”Coupling for Eclipse”
(int_eclipse.pdf).
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Supported Eclipse IDE and CDT Version Combinations

Eclipse 4.5 (Mars) with CDT 8.7 & 8.8
Eclipse 4.4 (Luna) with CDT 8.4 & 8.5 & 8.6
Eclipse 4.3 (Kepler) with CDT 8.2 & 8.3
Eclipse 4.2 (Juno) with CDT 8.1

Eclipse 3.7 (Indigo) with CDT 8.0

Eclipse 3.6 (Helios) with CDT 7.0

Eclipse 3.5 (Galileo) with CDT 6.0

Other versions may work, but they have not been tested by Lauterbach.

Please note that we cannot test, debug and support installations with modified Eclipse or CDT
components.

NOTE: For using the GDB connection, the CDT suitable version must be installed.

Documentation Updates

The latest version of this document is available for download from:
http://www.lauterbach.com/eclipse/cdtplugin/doc/int_eclipse_gdb.pdf
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Installation

Requirements

. An Eclipse installation, with the adequate “Eclipse C/C++ Development Tooling” CDT version as
listed in the Introduction section, is required and it should be configured for Java Runtime
Environment (required minimum is JRE 1.6).

. A TRACEB32 installation of the required target architecture is needed. The minimum software
version depends on the architecture used.
. In case of need, a correct hitp-proxy configuration for download and installation has to be
configured.
NOTE: Set the http-proxy configuration in the Eclipse dialog Window > Preferences,

in the section Install/Update or in General > Network Connections.

(The exact location depends on the Eclipse version used.)
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Lauterbach TRACE32 Eclipse Plug-In

Install the Plug-In

1. Open the Eclipse installation dialog Help > Install New Software (Eclipse 3.5 and later). The
exact dialog sequence and naming has changed with almost every major Eclipse IDE version.

2. Enter the adequate path as shown in the screenshot below:

- For Eclipse 4.2 and later: http://www.lauterbach.com/eclipse/cdtplugin/.

- For Eclipse 3.7: http://www.lauterbach.com/eclipse/cdtplugin/3.7_eclipse_updtaesite/.

- For Eclipse 3.6 and 3.5: http://www.lauterbach.com/eclipse/cdtplugin/
3.6&3.5_eclipse_updatesite/. (This version is no longer maintained)

type filter text

Mame

L+ Lauterbach TRACE32 GDB connection

Select All | [ Deselect Al

Details

Show only the latest versions of available software
V| Group items by category

Show only software applicable to target environment

V| Contact all update sites during install to find required software

4 (000 Lauterbach TRACE32 update site for Eclipse 4.2 and later

= Install B =
Available Software
c ; at you wi install. S
“heck the items that you wish to install ‘ J=
Work with:  Update Site - http://‘www.lauterbach.com/eclipse/cdtplugin/ - Add...

Find maore software by working with the "Available Software Sites” preferences.

Wersion

L0

V| Hide items that are already installed

What is already installed?

Bacl Mext Finish

Cancel

3. After selecting the adequate plug-in version in the Install dialog, please, follow the Eclipse

installation wizard.

NOTE: Please make sure you have set up correct http-proxy settings for Eclipse
before you start the plug-in installation.
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4. For Eclipse 4.2 and later the plug-in is signed, so you may be prompted to confirm trust to the
Lauterbach signature:

= Selection Needed | = | = ﬁ
Do you trust these certificates? Lauterbach GmbH o=
H =

Lauterbach GmbH; Lauterbach Consulting SARL; Lauterbach GmbH

General | Details |

Issued to
Common Mame Lauterbach GmbH
Organization Lauterbach GmbH
Organizational Unit  Lauterbach Consulting SARL
Issued by
Common Mame Lauterbach GmbH
Organization Lauterbach GmbH
Organizational Unit  Lauterbach Consulting SARL
Validity Dates
Walid From 09 June 2015
Walid Until 09 June 2025

Select All | [ Deselect Al

4 Lauterbach GmbH; Lauterbach Consulting SARL; Lauterbach GmbH
Lauterbach GmbH; Lauterbach Consulting SARL; Lauterbach GmbH

@ CoxJCe=|f| @

h

5. For Eclipse 3.7 and earlier, please confirm unsigned installation:
| N

B 3

& Security Waming

Warning: You are installing software that contains unsigned content. The authenticity
l * or validity of this software cannot be established. Do you want to continue with the
installation?

[ ok [ cancal ][ Details>>

L%

6. When prompted to do so, please restart Eclipse.

Congratulations, plug-in installation is complete.
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Create Launch Configurations

The Eclipse plug-in can start the TRACE32 PowerView via an Eclipse Launch Configuration.
This document refers to Debug Configuration dialogs only.

A demo exist under http://www.lauterbach.com/eclipse/cdtplugin/demo/demo_cdtplugin.zip. It
contains:

- An Eclipse (Luna) with the plugin installed.
- A TRACES32 Simulator for ARM.

- An Eclipse workspace that contains: an ARM project and a GDB executable for ARM
(windows).

This demo was used to make the below screen shots. To be able to use it without any further changes, you
need to unzip it under “C:\demo_cdtplugin\’. If this is not possible, you will need to adapt the paths.

These steps are valid for Eclipse 4.4 (Luna), 4.3 (Kepler), 4.2 (Juno), 3.7 (Indigo), 3.6(Helios) and 3.5
(Galileo). The GDB connection is configured via an Eclipse Launch Configuration.
1. Open Run > Debug Configurations to set up a Debug Launch Configuration.

2. In the Debug Configurations dialog select LAUTERBACH TRACE32 and add a new
configuration with the context menu (right mouse button), opening this dialog:

& Debug Configurations RS
Create, manage, and run configurations
o ET.
= X | e Mame: arm Debug

type filter text E Main 35 Debugger

E C/C++ Application , o

T C/C++ Attach to Application e BE D

E C/C++ Postmortem Debugger Chdemao_cdtplugin'Warkspace-lunatarm'\Debugarm. exe

T CC 1 icati R =

Ll N i F‘em.ote .Appllcwtlon Variables... | | Search Project... | | Browse... |

2 Eclipse Application

T GDB Hardware Debugging Praject:

T GDB OpenQCD Debugging amm Browsess

T GDB SEGGER J-Link Debugging o . .

%) Java Applet Build {if required) befare launching

31 Java Application Build configuration: | Use Active v|

Ju MUnit

Jti Junit Plug-in Test Enable auto build Disable auto build

P Launch Group @) Use workspace settings Configure Warkspace Settings

A LAUTERBACH TRACE32

A arm Debug Caonnect process input & output to a terminal

& 05Gi Framewark

i Remate Java Application

4 1 3

i K Apply Revert

Filter matched L7 of 18 items

':\?)' Debug ] | Clase
3. Choose and enter a name for your Debug Configuration.
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4. Set the Project field to the name of the Eclipse project with your source files.

5. In the field C/C++ Application enter the path to the application file.
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6. Go to the Debugger menu. Then, in the field GDB debugger enter the path to the GDB
application.

El Main | %5 Debugger

/| 5top on startup at:  main Advanced...

Debugger Options
Main | Connection | TRACE32 | Edit Configuration File

GDB debugger:  C\demo_cdtplugin\Workspace-luna\arm-eabi-gdb.exe Browse...

(Warning: Some commands in this file may interfere with the startup operation of the debugger, for example "run".)

GDB command set: |Standard v|

Protocol: |mi v|

Verbose console mode

Use full file path to set breakpoints

7. Go to the connection list and enter your GDB configuration.

El Main | %5 Debugger

/| 5top on startup at:  main Advanced...

Debugger Options

Main Connection | TRACE32 Edit Configuration File
Main [TCP |

Host name or IP address:  localhost

Port number: 30160

8. Go to the TRACES32 tab. In the field TRACE32 executable, enter the path to the TRACE32
PowerView application. The file name of the TRACE32 executable depends on the target
architecture (For example t32marm.exe for ARM).

El Main %5 Debugger

V| Stop on startup at:  main Advanced...

Debugger Options

Main | Connection | TRACE32 | Edit Configuration File

TRACE32 executable: Chdemao_cdtplugin'simarm'it32Zmarm. exe Browse...
Configuration file: Chdemao_cdtpluginisimarm'.config.t32 Browse...
Practice script: Chdema_cdtplugintsimarm't32Z.cmm Browse...
Initial working directory:  Cdema_cdtplugin'simarm Browse...

Automatically start TRACE32 with the debug configuration

Start TRACE32

NOTE: The TRACE32 GDB backend supports the architectures ARM, ARM64, PowerPC,
MIPS32, SH, MicroBlaze, 68K, Intel x86, Intel x86 x64. Other architectures could
be supported on request.
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9. In the field Configuration File enter the TRACES32 configuration file to be used with the
executable. TRACES32 has to be configured for use with the GDB backend by adding the
following lines to the configuration file:

<- mandatory empty line
; TRACE32 GDB backend configuration <- optional comment line
GDB=NETASSIST
PACKLEN=1024
PORT=30000 ; PORT NUMBER
PROTOCOL=TCP

<- mandatory empty line

NOTE: PACKLEN specifies the maximum package length in bytes for the socket
communication.

PORT specifies the port number for communication. The default port is 30000.
If this port is already in use, try one higher than 30000.

PROTOCOL specifies the used protocol (TCP or UDP). Default is UDP.

An empty line before and after the text block is required!

Comment lines in the configuration file are ignored.

If the GDB configuration is in the end of the file and is correct, the launch
configuration may show an error message. Try to add another empty line to the

end of the file.

For more information, please refer to "TRACE32 as GDB Back-End”
(backend_gdb.pdf).

10. In the field PRACTICE script, you can enter the TRACE32 cmm file.

NOTE: When started, If the PRACTICE script is not specified, TRACES32 will looks for a
file with the name t32.cmm in its initial working directory. If the file is found, the
built-in PRACTICE interpreter will automatically read and execute this file as its
Startup Script.

11.  Set the Initial Working Directory for TRACE32 when it is launched by the plug-in. This directory
will be the initial working directory for scripts started in TRACE32.

NOTE: TRACES32 displays the initial working directory when you enter the PWD (="print
working directory”) command directly after TRACE32 starts.
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NOTE: TRACES32 can be opened with the Start TRACE32 button or with pushing the
Debug button. If the PRACTICE script needs too long time to finish, Eclipse
may not be able to connect (time out). Please launch TRACES32 before starting
debugging.

12. The Edit Configuration File tab gives the possibility to modify, save, restore and add
automatically a GDB configuration. With this option the plug-in will use the port number value
entered in the Connection tab.

NOTE: The TCP port is automatically corrected (any change in the Connection tab will
be set to the configuration file and vise versa). This will only work if there is a
valid GDB configuration bloc in the configuration file.

El Main %5 Debugger

V| Stop on startup at:  main Advanced...

Debugger Options
Main | Connection | TRACE32 | Edit Configuration File

File Mame : Cdemo_cdtpluginisimarm’.config.t32

PEI=5IM -

PRINTER=WINDOWS

m

GDB=METASSIST
PACKLEM=1024
PORT=30160
PROTOCOL=TCP

Save Restare Add GDB configuration
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13.

With a correct configuration in place, click the Debug button to launch TRACE32.

& Debug - arm/arm.c - Eclipse SHIEE X
File Edit Source Refactor Mavigate Search Project Run  Window Help
O REER SN RS TS WA IO TRIG® I v Gy
s<ig | a’Java == Plug-in Development @C;"C++
45 Debug 7 [) © = O o Variables S Breakpoints i) Registers 52 |\ Modul EB|Cics Y5 0
4 jk arm Debug [LAUTERBACH TRACE3?] Mame Value i
a {72 TRACE32 GDB {09/07/2015 10:40) {Suspended) 4 B Lain
oron B
o Thread [1] (Suspended) 1010 ) i
oo
= Lmain{) arm.c:592 0:00008h0e o q
oo
s Chdemo_cdtplugintWorkspace-lunatarm-eabi-gdb.exe 1010 1) 2
oo -
s Chdemo_cdtplugin'Workspace-lunatarm' Debug'arm.e S e
] 1 ¢
] [T r e '
= B8 == Disassembly (7 = g
{ & Enter location here - | &
int j;
char * p; =
. 00003baz : ldr r3, [pc, #364] H
-\.-tr%pplearra',-'[@][@][@] =1; Q000shad:  movs r2, #1
a-tr%pplearra',-'[l][@][@] = 2; Q0005bas: strb r2, [r3, #0] L
vtr%pplearray[ﬁ][l][ﬁ] = 3; 00005b0s:  1dr r3, [pc, #356] ;|5
vtripplearray[@][@][1] = 4; 00005bhda mavs r2, #2
aaoashac : strb r2, [r3, #12]
func2(}; ¥ o0000shoe:  lde r3, [pe, #352] ;
@0ashla: movs r2, #3
func2a(); Qa0ashl2 : strb r2, [r3, #]
i 00095h14 : ldr r3, [pc, #344] H -
funec?hi h: ————— .
- ) ] 1 ¢
& Console &% = IBEEF@E #2-00-- 0
arm Debug [LAUTERBACH TRACE32] Chdemo_cdtplugintWorkspace-lunatarm'.Debug'.arm.exe (09/07/2015 10:40)
9 plug p 9
" 2
Writable Smart Insert 502:1
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Open TRACE32 from the Toolbar

The TRACE32 PowerView can also be executed through the Lauterbach Logo button in the Eclipse C/
C++ Perspective toolbar. The Lauterbach Logo button executes the TRACE32 PowerView with
parameters entered in the Debug Configuration.

Add the Lauterbach Logo Button

Normally, the Lauterbach Logo button in the tollbar is automatically added. But, if it is not showed in the
toolbar:

1. Open the Windows menu.
2. Choose Customize Perspective.

3. Activate the command group Lauterbach TRACE32.

& Customize Perspective - Debug L@éj

Tool Bar Visibility | Menu Visibility | Command Groups Availability | Shortcuts

Choose which tool bar items to display.

Tool Bar Structure:

. = File
. [ = Debug
a [J] [ Lauterbach TRACE32
7| i Lauterbach TRACE32
- [¥] = Editor Presentation
. [¥] ] Launch

. [V] =] Search
. [ =] Navigate
7| =] help

Filter by command group

|/':?>| oK ] | Cancel
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Troubleshooting

Eclipse

Failed to Connect to TRACE32

Symptoms: Launching TRACES32 from Eclipse works, it starts up fine. However, after some time-out, Eclipse
displays the message “Target selection failed”.

Please make sure the TRACE32 GDB configuration is set properly.

The TRACE32 configuration file must contains:

<- mandatory empty line
;T32 API Access ;<- optional comment line
GDB=NETASSIST

PACKLEN=1024

PORT=30000 ; PORT NUMBER
PROTOCOL=TCP

<- mandatory empty line

and the PORT number is the same as in the connection tab.

For a detailed example, please see “Create Launch Configurations”, page 7.
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Help Us Help You

Export the Eclipse Error Log

Please include the full Eclipse Error Log as a file in your support request:

1. Open the Error Log view in Eclipse with Window > Show View > Error Log.
2 Click the Export icon on the Error Log view toolbar.

3. Save the log as a file.
4

Attach this file to your support request.

Export the Eclipse Configuration

Export the Eclipse configuration settings in text form to the clipboard. With this we can check your Eclipse
configuration for any missing or outdated components.

1. Open Help > About Eclipse.
2 Click the button Installation Details.
3. Select the Configuration tab.

4, Click Copy to Clipboard.

5

Paste the clipboard content into your support mail to Lauterbach.
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